Status
Maintenance
Previous incidents
Get in touch
Back to overview
Resolved
Testing
Sep 19, 2026 at 4:59pm UTC
Affected services
app.niduna.com
Resolved
Sep 19, 2026 at 4:59pm UTC
Testing
Affected services
app.niduna.com